Chevy High Performance
Click here to find out more!

Left Turn Signals won't flash - 75 Nova

  
Chevy High Performance
Item Posts    Sort Order

Left Turn Signals won't flash - 75 Nova

 
No Business No Business
New User | Posts: 1 | Joined: 11/13
Posted: 11/01/13
01:55 PM

My left rear turn signal went out and when I went to replace the bulb I noticed a lot of corrosion in the socket.  So I replaced both the bulb and the connector. The bulbs light now, front and rear, but do not flash.  The right side flashes fine.  

Dave632 Dave632
Addict | Posts: 2225 | Joined: 07/08
Posted: 11/01/13
03:38 PM

Lack of adequate ground is usually the reason for this problem.  
[[SUPPORT AMERICAN CARS, STOMP A RICE CAR TODAY.]]

wayne712222 wayne712222
User | Posts: 205 | Joined: 10/13
Posted: 11/01/13
08:13 PM

exactly...

Sidemarkerlightsflashlikethis Zps7e46070e

Bulb External Ground Wire Zps3bf5f3bd

see the metal tabs... those are usually the only thing that usually grounds the bulbs and thats thru the tail light housing..

note that there is a small passage at the 8 o clock position.. just right for adding and addiditional  ground wire..

Stoptaillightsocketstraighin Zps5d303b13


you might also want to use a circuit tester... and PROBE the YELLOW and GREEN wires coming out of the turn signal switch connector...

yellow and green are rear turn and stop signals..

dark blue and light blue are front turn signals..

there is a small chance that you have a bad turn signal switch.. or a corroded connector where the flat harness from the front of the car connects to the tail light harness for the tail lights..