Chevy High Performance
Click here to find out more!

91 "J" Body starting and running issue

  
Chevy High Performance
Item Posts    Sort Order

91 "J" Body starting and running issue

 
netwarrior36 netwarrior36
User | Posts: 100 | Joined: 10/08
Posted: 10/01/13
07:48 PM

Today I changed my plugs and wired, didn't mess with anything, started the car it ran smoothly. After I got off of work I started driving and in the mid rpm range the engine was jerking really hard but in low rpm and high it was smooth.  last time this issue happened i changed the ICM and the issue resolved itself but in doing so the retainers for the wire spades on the ICM crumbled from age and heat so I had to remember which order they went in, well no issue then to get it done. so the jerking continued so i stopped into my work (autozone) and pulled the ICM and ran in and tested it but it tested good...so i had to put it back in...i got the wiring wrong i guess and it won't start then i changed around some wiring, only to discover the on the 3 pin side there is a ground with an external ground running off of it...well that external broke off the distributor so i've gotta figure how to wire that but overall the biggest issue is getting the wiring straight...anyone got a diagram? i checked a haynes/chilton and i couldn't find a single matching diagram to get it back together so now it's stuck at my work...before i got picked up i checked the codes again for the heck of it and it went the flash...flash,flash ok 12 then a few moments later it was flash...flash...flash,flash,flash,flash,flash ok a 25 well that's a manifold air temp sensor but i really don't know why all this happened so suddenly let alone why it acted as it did when i changed the plugs and wires.  
--------------------
"If it breaks it was good, and if it doesn't break it's bad."

1978 Chevrolet Nova two-door hatchback

netwarrior36 netwarrior36
User | Posts: 100 | Joined: 10/08
Posted: 10/01/13
08:05 PM

I"m sorry for the double post i'm unsure as to how to remove a thread.  
--------------------
"If it breaks it was good, and if it doesn't break it's bad."

1978 Chevrolet Nova two-door hatchback

netwarrior36 netwarrior36
User | Posts: 100 | Joined: 10/08
Posted: 10/01/13
08:38 PM

I've found the wiring diagrams to help me out but i'm still concerned about how to fix the rough running issue at mid level rpms  
--------------------
"If it breaks it was good, and if it doesn't break it's bad."

1978 Chevrolet Nova two-door hatchback