Chevy High Performance
Click here to find out more!

optispark on LT1

  
Chevy High Performance
Item Posts    Sort Order

optispark on LT1

 
johnnyvrod johnnyvrod
New User | Posts: 2 | Joined: 03/13
Posted: 03/30/13
05:50 AM

Hey guys great mag!! I have a 87 S-10 that I put the motor and trans out of a 93 z28 with the factory fuel injection and computer.I had the computer reprogrammed and wiring harness built for this app. My question for you is I have been reading in your mag as well as other sources that the optispark distributor had some issues. What are these issues/symptoms and what is the cure,if any,other than replacement in the aftermarket.Also what is a good fuel rail pressure for this set up.


Thanks for your help, Johnny Williams
Guyton, Ga.  

redneckjoe69 redneckjoe69
Addict | Posts: 2337 | Joined: 03/10
Posted: 03/30/13
06:28 AM

one issue was them getting water or oil inside.   the cure was to drill a small hole in the bottom and epoxy a nipple on.  run a hose from the nipple to a vaccum source.  somebody had pics on here.  

waynep712222 waynep712222
Enthusiast | Posts: 251 | Joined: 03/13
Posted: 03/30/13
06:48 AM

there are 5 or 6 various optispark articles spread out thru the many magazines here..

some of them show the proper way to Vent the optispark.. so the ozone thats created by the arc flash from the tip of the rotor to the cap terminals does not become so concentrated that it corrodes the various components ...

http://www.chevyhiperformance.com/sch/02/optispark/articles/?searchSource=Group

you will also want to make sure that the short pigtail that connects the micropack optispark 4 pin connector to the weatherpack 4 pin connector are not loaded with corrosion... if its got green grease its going to fail..

you will also want to inspect the sides of the ignition coil.   high voltage leaks thru the insulation will create a misfire that will drive you crazy...

let me fill you in.. a shop i worked at.. a LT1 camaro came in.. with a misfire..  the bosses said they were going to fix it..  i said.. the coil is bad.. change that first..  nope... they went straight for the optispark cap and rotor... that did not fix it.. so they decided to change the spark plugs... and then the wires when they broke in attempts to remove them..  still had a misfire...

i had a new coil sitting on my tool box...   while they were off in the office.. i swapped it on..  when they came back.. the misfire was gone..  i tossed them the old leaky coil..  said. i fixed it.. thats what you pay me for..

COIL Highvoltageleakage


as for the fuel pressure.. go with the stock pressure... 38 or 39 PSI...

when you drive it... monitor the various live data values...

i am taking that you have some kind of OBD1 scan tool... not just a code reader...

you may also want to preemptively replace the engine coolant temp sensor..  its under 20 bucks and they are KNOWN to fail...  driving L98 and LT1 owners crazy...  this is not for the gauge.. or the fan.. it tells the computer how hot the coolant is.. so proper air fuel ratio can be selected..

in looking at the live data...  to decide if you need more fuel pressure...  

you will want to look at the integator and block learn numbers while idling .. and while at crusing speed.. but also at HIGH speed..   128 is perfect..  if its far off.. you will be having air fuel ratio issues.  something is not correct..

throttle position sensor voltage is critical on these... should be 0.53 with the engine idling.  IAC should be between 20 and 50. (idle air counts) these engines should idle warmed up at 475 to 500 RPMs if they are working properly...

use care when selecting an alternator..  these have a time out that turns off the charging when the engine returns to idle..  its either a 2.5 second or a 10 second time out.. the PCM will know that this is happening and will open the IAC slightly at 9.5 seconds.. this allows the engine idle to stabilize at a very low idle speed...  the alternator and the computer do not talk about this.. its just happens because of the programming.


thats going to be a monster of a truck ...  

waynep712222 waynep712222
Enthusiast | Posts: 251 | Joined: 03/13
Posted: 03/30/13
07:05 AM

there are a LOT of good articles on the LT1 and LT4 on the link i posted... be sure to take your time as the distributer articles are spread out over quite a few of the pages.. not just the first page..  

Dave632 Dave632
Addict | Posts: 2220 | Joined: 07/08
Posted: 03/30/13
08:37 AM

I had an opti spark failure on my 95 Camaro and it was NOT due to moisture.  Mine already had a vacuum line on it.
The integrated circuit in the unit failed and would not allow the motor to rev above 3500, below that it ran fine. That IC is not available separately either.
The sad thing is that I went to Auto Zone and bought a so called rebuilt unit.
This, (rebuilt by incompetents), unit had the exact same trouble as the original.
I have had to learn this lesson several times. Do not buy anything that is electrical from some company who says they rebuilt it. Almost without exception they do nothing but clean the unit and put it on some kind of inadequate test.
I remember changing a starter 5 times before I got one that worked in a Ford PU.
My son had a similar experience with a Camaro. All the Ford starters would not crank well when they were hot. The Chevy ones cranked poorly under load but were fine without load which is probably how they are tested.
MSD makes a replacement for the opti spark but I do not know how well it works and it is expensive.  
[[SUPPORT AMERICAN CARS, STOMP A RICE CAR TODAY.]]

redneckjoe69 redneckjoe69
Addict | Posts: 2337 | Joined: 03/10
Posted: 03/30/13
10:09 AM

another common mod is to step the ICM and coil off the head by stacking a few washers behind the mounting bracket.    it helps with heat disipitation.   ICMs are about $100! Shocked  

kingasad kingasad
New User | Posts: 3 | Joined: 03/13
Posted: 03/30/13
11:49 AM

Hello I have a 99 sub and im getting a rich and lean code in bank 1 bank 2 can anyone help me  

pepsi1 pepsi1
Guru | Posts: 1718 | Joined: 09/11
Posted: 03/30/13
04:17 PM

Wayne, RedneckJoe, Dave, All A Plus +1.

I did consulting work for a GM Dealership in the emid '90s. This one day it was pouring rain, and this State Trooper drivers his cruiser in. The noise was so loud, not knowing better you would think it had a rod knock. I told the servive mngr. I want this thing.
  This thing shot a spark of #1 plug wire to the (A) arm on that side (drivers Side). Maybe 10". That was some crack you could hear. You have to respect those optisparks. (I was hit with a magneto) and I always respected those things ever since.. Even a good working points ignition can make you wet your pants....

Bob  

pepsi1 pepsi1
Guru | Posts: 1718 | Joined: 09/11
Posted: 03/30/13
04:21 PM

Give us some information of your Suburban

How many miles om the Suburban?

When was the last time it was tuned up?

Bon  

kingasad kingasad
New User | Posts: 3 | Joined: 03/13
Posted: 03/31/13
01:10 PM

I had engine replaced two ago but I have almost 250k miles I had three O2 sensors changed along with thermostat EGR sensor crank sensor spark plugs  

68scott385 68scott385
Guru | Posts: 1990 | Joined: 10/09
Posted: 03/31/13
05:10 PM

I have a 97 1500 5.7 Vortec, with the GMs funny colored anti-freeze, it would dissolve intake gasket and burning the coolant would cause O2 sensor failure and catalytic converter failure. I stopped using the funny colored anti-freeze when I changesd intake gaskets the second time in 2008. Haven't had any problems since.

Food for thought...just some experience to share  
68scott385 68scott385 68scott385

kingasad kingasad
New User | Posts: 3 | Joined: 03/13
Posted: 04/02/13
10:00 AM

68scott385 my engine light comes on and off  

68scott385 68scott385
Guru | Posts: 1990 | Joined: 10/09
Posted: 04/02/13
11:13 AM

Failed O2 sensors and catalytic converters will turn on the check engine light and leave trouble codes in the computer.

When the light comes on, use a code reader and see what the trouble codes in the computer are. Many auto parts stores will read the codes for free if you don't have a reader of your own.  
68scott385 68scott385 68scott385