Chevy High Performance
Click here to find out more!

need help... cant understand whats wrong

  
Chevy High Performance
Item Posts    Sort Order

need help... cant understand whats wrong

 
1971belair 1971belair
New User | Posts: 6 | Joined: 03/13
Posted: 03/19/13
10:00 PM

is there something different if i use a electronic distributor instead of my old points its a 400 small block chevy engine 2BBl i got a new distributor form a 76 camaro 350 5.7L its the same size and it sits fine starts but engine stall after a couple of minutes i dont know if thats the problem or the wire set  

waynep71222 waynep71222
Enthusiast | Posts: 448 | Joined: 03/12
Posted: 03/20/13
01:26 AM

i am taking that this did not happen when you had the points type distributer...

do you have a timing light and a circuit tester..???


hook up the timing light to monitor the high voltage spark output from any wire

pull the 2 screws out of the coil cover and remove the coil cover..   yes.. you may have to remove the wire retainer..

shove the probe of the test light into the cavity with the red wire... so you can monitor the power to the HEI...

start the engine and look at the test light and the timing light flashing.. which one dies first when it stalls from a fast idle..


the test light should stay on until you turn the key off...

if the timing light stops flashing just at the engine stalls but before it stops turning.. then there is a problem inside the HEI...  either the ROTOR is bad... the module..  the pick up coil or the ignition coil in the top of the cap..


the rotors have been found many times to be burned thru..  must inspect the underside..

ignition modules have to be installed onto a small amount of dielectric tune up grease or they will over heat and be ruined..  the dielectric tune up grease allows the transfer of the massive heat generated by the transistor inside the module to be dispersed to the body of the distributer and the airflow takes that heat away..    modules can be tested in most parts stores.

the pick up coils have died .. there is a test.. if the wiring connection to the end of the module from the pick up coil has green grease.. its going to need a new pick up coil... as the green is dissolved copper from the pick up coil wire..

the ignition coils on top of the cap also go bad..  one can examine them for signs of high voltage leakage.. by looking at them... pictures in the morning...


if the test light stays on and the timing light continues to flash until the engine has come to a complete stop.. then it might be a fuel issue.. or something else  

pepsi1 pepsi1
Guru | Posts: 1718 | Joined: 09/11
Posted: 03/20/13
05:19 AM

1971Belair

Make sure your battery voltage is 12.4 to at least 12.7 VDC. If not charge the battery and try to monitor it. "A high percentage of electrical problems" can be related to low battery voltage...
  Before you start to do any testing. Remove the distributor cap and make sure the ground strap is in the distributor. (Some people remove them and then problems start) You don't know the history of the distributor.
  Just check for any carbon tracking, cracks, check the rotor cap for any of the same problems.
  The ignition module can and will overheat, if dieeletric grease is not used under the ignition modle, or has dried up.
  Now if all that checks out okay, and there are No problems test the ignition mogule.
  I understand from your post that what happens is the engine fires, runs and then shuts off. If I read this correctly you can try this to test the ignition module, but if your engine shuts off quickly you will need a helper.
  In the distributor cap you will have the power lead (Big Red Wire) and a Tach lead that should be marked on the cap..Now with all that said.

1.Using a test light, at the tach lead of the distributor cap "it should be marked "TACH" on the cap connections

2.Keep the test light hooked to the tach lead in the cap. Now when the engine is running the "Test Light Should Pulse" if the module is working properly.

3.If the light pulses and then stops (REPLACE THE IGNITION MODULE) or check for a poor electrical connection to the Ign. Module itself....

4.Just make sure all the eletrical connections are clean with NO dirty connections anywhere....

Bob