Chevy High Performance
Click here to find out more!

350 Oil Pressure

  
Chevy High Performance
Item Posts    Sort Order

350 Oil Pressure

 
Huntertb1 Huntertb1
New User | Posts: 1 | Joined: 04/08
Posted: 04/20/08
05:44 PM

I bought a used chevy 350 motor that I know was taken care of, I changed all of the seals and gaskets, timing chain and gears and oil pump and screen.  I didn't want to have to mess with these things for a long time while the motor was in the truck.

I finally got everything hooked up and hit the hey and she fired up third crank and runs perfect....

I have 2 issues now though, first issue is there is smoke coming from center ports on both sides of my manifolds, there is NO foreign chemicals on the manifolds that I can see, I was wondering if it was the new manifold gaskets I put it.  Now that I think about it, 1 side was cardboard and the other side was the metal mesh, I installed the cardboard side facing the block, maybe the cardboard is burning?  If so, why only the center ports on both sides?

Next more important problem is oil pressure, I was told that I have to prime the oil pump and I was told that I didn't have to.  (I also put a new oil pressure sending unit on the motor) when I fired it up the gauge pegs out, like the unit is bad, and I don't think I have any oil pressure( I pulled the oil filler cap off, and didn't see any oil slopping around in the valve cover) How do I tell for sure if I have any oil pressure? I haven't heard any ticks from the lifters, which is what my last motor did when the oil pressure was to low, but I want to be sure.  I won't run it for more than a minute or so, as the smoke gets bad from the manifolds.

There is a canister that appears to be oil related that has no wire plugged into it, it comes off of the block right above the oil filter adapter could that be why I my oil pressure reading is not right?


my questions are:

How do I check for Oil pressure ( I just want to know if I have ANY circulation at all right now)

Why might my exhaust manifolds be smoking on the middle ports?

Thanks in advance for any suggestions.

I have never changed an oil pump before and I probably screwed up and will need to drop the oil pan and pull it out and see whats up, but if I can avoid that I'll try anything else first.  

bbfx88 bbfx88
New User | Posts: 40 | Joined: 12/07
Posted: 04/21/08
03:05 PM

I guess no one knows a thing about oil pressure on this forum....I have posted a oil pressure question on this forum and it goes unanswered as well...they all want to argue about big cams and SB 305's.....I'll give a shot though....

exhaust manifolds smoking:  I dont think engine was running long enough to burn off oil from hands, fingers, etc.  Gaskets sound backwards but should be fine...

Oil pressure:  my suggestion to you is buy a mechanical pressure kit and install it in place if the electric unit to get a true reading...and yes you should have primed the oil system if possible..once you installed the new oil pressure gauge...unplug your distributor power or coil wire completely and turn the engine over with the starter and watch the oil gauge for pressure..you should see within 4-5 seconds of cranking.(if just pulling the coil wire off watch for FIRE DANGER from stray spark)  If you get pressure at the gauge it should be ok to run to operating temps....if your still worried about oil to the rockers..take the valve cover off and start the thing up and take a brief look...could get messy though and cause temp smoking again and fire  danger so be carefull...just takes a second to check...hope this gets you pointed in the right direction and please don't correct my spelling, puntuation, or grammer....LOL....its my bad typing....